Rode Caster Pro 2 / Audition / Asio Drivers

I have a recurrent problem and perhaps someone in the MRC Community has faced this and may know how to help me, please.

I bought the Rode Caster Pro 2 when it was launched.

I work with Adobe Audition and Windows 11 and as I produce Podcasts I need to record in multitasks.

The problem is that I get losing connection between Audition and RCP2 (Rodecaster Multitrack / Chat not working message) or , even if eventually I momentarelly get the connection, then any audio file plays in Audtion with strange noise. I already checked the sample rates…

I tried everything, I was with Audition Help Desk more than 6 hours this week.

Rode only gave me the updates sugestions of Asio (from the official link they provide in their website).

I even updated the GPU drives as per Adobe Audition one specialist sugested.

The Audition connects well with RCP2 in MME mode.

I really don’t know what else to do, If I could have any tiop of advice from anyone would be highly appreciated.

I belive there is a problem with the stability of the Asio drivers. I even tried with Reaper App and I get no connection with RCP2, also…

Thank you ever so kindly.

I’m sorry to hear about the persistent issue you’re experiencing with the Rode Caster Pro 2 and its compatibility with Adobe Audition on Windows 11. ASIO driver issues can be particularly frustrating. Here are a few potential solutions and troubleshooting steps you might consider:

  1. USB Ports: Try switching to a different USB port on your computer. Preferably, use a USB port that’s directly on your motherboard (rear of the computer) rather than a front-facing or hub port.
  2. Cable Issues: Consider testing with another USB cable to rule out any cable-related issues.
  3. Alternate Software: You mentioned using Reaper, but you can also try other DAWs like Ableton Live, FL Studio, or even Audacity to see if they can detect and work with the RCP2. This can help isolate if it’s strictly an Audition issue.
  4. System Compatibility: Although you are on Windows 11, consider if there’s any recent Windows update that might be causing compatibility issues. Try checking forums or communities dedicated to Windows 11 audio production to see if others are experiencing similar challenges.
  5. Disable Other Audio Devices: Temporarily disable or unplug other audio interfaces or devices from your system. There might be a conflict between devices.
  6. Reinstall RCP2 Firmware: Although you’ve probably already done this, it’s worth mentioning. Sometimes reinstalling or updating the RCP2 firmware can resolve lingering issues.

I hope one of these suggestions offers a solution or at least a clue as to what’s going on. Wishing you the best of luck in resolving the issue.