NDI Plugin Not Showing On OBS For Mac

Hi,

I have downloaded the NDI plugin for OBS several times, but it is not showing on OBS. I am on a MacBook Pro. I am having an issue with lag between the audio and video on skype calls in window capture with OBS.

I have quit out of OBS and re-opened it and I have restarted my computer. Any ideas on what to do?

You need to make sure you’re installing the very latest version of the OBS NDI plugin. Unfortunately the OBS website doesn’t always link to the latest release which can always be found at the top of this page: https://github.com/Palakis/obs-ndi/releases

Still not working for me

Same, still not appearing on my latest version of OBS 23.2.1 after re-installing multiple times and installing NDI plugin. https://github.com/Palakis/obs-ndi/releases suggests A new version compatible with OBS 23.2.1 will be available shortly - does anyone have any temporary help? Thanks

Same here , did you manage to solve the issue ?

So I’ve got the latest versions ( as of 3/23/2020 ) of the NDI runtime, plugin, OBS and NDI enabled Skype - all downloaded and installed and recognized by OBS but … black screen. I’ve read countless suggestions, tried them all except going to older versions. This is on Windows 10 but apparently, per this thread, it happens on Mac. Oddly, on linux, OPS, Skype and NDI play well together however, there’s no NDI version of Skype for Linux. I have successfully received an NDI source from another machine and can get screens and windows to work in OBS. I’ve run out of things to try.

I am having the same problem. Using the “Discovery” utility for Mac, I browsed the mDNS (multi-cast DNS server) where NDI streams are posted for other things to discover. On my MacBook the entries are being created without a hostname and port number, where as on Windows 10 they are created correctly with a host name and port number (and some other info). As a result I think nothing knows how to connect to the Mac NDI streams (does not know host and port to use).

I now have something working. My basic misunderstanding was that I thought NDI enabled Skype and OBS could work on the same machine. I obtained another Windows box, installed Skype, turned on NDI and am now getting nice Skype inputs on OBS.