Issues with recording studio setup - weird glitches in recordings

Hello there,

I’ve having some issues with my instructional videos. The issue is that I’ve experiencing weird glitches in my recordings.

As you can see in the screenshot they appear not in a certain pattern. They seem to be generated somewhere in my setup but I can’t determine where the issue comes from.

Something about my setup:

Recording device: Panasonic HC-X1 4K video camera


  • Two t.bone free solo Twin PT 660 MHz wireless systems for total of 4 wireless mics
  • Behringer TM1 (i think)


  • Behringer XENYX 1204 mixer

System: Heavy duty PC using OBS to record.

We’ve connected both thoman wireless systems to the camera to record the audio along with the video to reduce the latency. Then both wireless systems to the 1204 mixer. This to have some control over the mics, and to be able to mute them easily. Also we do some low cut and some gain on the mixer, for the rest we don’t use any options on the mixer.

Everything is connected with XLR cable. It occurs while using the wireless mics as well as the behringer. I’ve even tried disabeling the filters of OBS. We use a little bit of a noise gate in OBS.

Some recordings do have these glitches and some don’t. And as far as I can tell as a bit of a novice on the audio recording part it really seems to be a “electrical glitch” and not something that is recorded but generated somewhere down the line

Hope somebody can relate to these issues and might be able to point me into a direction to search for a solution.

Hi Harold 109… Have a look at this post and see if it helps with your problem:- Audition skipping in the recording? (recorded file has jumps)


Thank you for your reply. I’ll be sure to test these options. The master/slave part of the story might be a thing. Although listening to the sound file Marissa posted it does sound a bit differently. I might take some time to test this out but it’s useful information.

If done correctly a sample can be found here:

The other thing that I am considering is fawlty XLR cables or something like that. The disk that I’m using is most likely a SSD disk so this might be less assumable? Please let me hear your point of view.

Hi Harold 109…

Thank you for posting your audio problem for us all to hear. I had a listen and at the moment I’m thinking it could be a ‘clock/sync’ problem between digital devices, however I would also do the following just to be sure…

  1. Charge the battery up for your camera and do a test using only the camera and its internal mic(s) using the battery as its power source, not the mains adaptor. Record a small section of audio/visual footage (30 secs should cover it) on to an SD card plugged into the camera.

  2. Once you have recorded onto the SD card remove it and then insert it into an SD reader connected to your computer. Copy the test file over to your computer desktop and then load into your DAW for inspection. Import the audio, do not send it wirelessly.

If this is okay, then redo the test but this time use the power adaptor and not the battery. Check the results again by moving the SD card from the camera to the SD reader just as before.

If you find your problem has returned it is possible that it is not your equipment but the power supply, either the adaptor, its connector or your mains electricity into your recording studio/area is at fault. The adaptor can be replaced if faulty but a problem with your mains is a lot tricker to sort out, this usually gets expensive if you are not a fully qualified electrician!… or you could get lucky just by changing rooms.

If your tests are once again free from unwanted artefacts then it’s time to try recording your Behringer TM1 mic directly into the the camera using the XLR lead supplied with the microphone. Don’t forget to switch phantom power on from the camera and shoot another short test. Check that you gain is set correctly then, once again test using the battery first and check in your DAW, and then if okay, with the power adaptor, check again to see and hear if the results are fine.

So if you get this far and you cannot reproduce the problem I would conclude that the equipment you have tested so far is in good working condition and that your electricity supply doesn’t need any work done on it.

Let us know how you get on with the above for now…



Thank you for such an extensive desciption on how to troubleshoot and to find a solution for this. When I’m able to do this testing I’ll surely let you know the results. I could take some time, since working from home since covid is still more standard than normal office hours.


Here’s an update on my part. Today back in the office and ready to do some testing.
As I’m used to. I can seem to reproduce the problem. This off course is quite difficult. Because I really tried to trigger the issue again. And now if it occurs again I don’t know how to handle when I’m in a recording session with colleagues. The weird thing is that it happened several times but not always. During webinars steamed with webinarGeek this issue never seemed to have happened. Both used OBS as a recording application.

So today I started to do a recording in the normal setup (and the wireless mic I normally use).

  • I did a recording of 1 minute with no sound at all. To see what happened. No glitches, the noise gate and Noise suppression in OBS worked fine Totally black and no unwanted noise or glitches.

  • I did a Recording of 1 minute of some music which I played with my phone in
    the wireless mic. This recording was fine no glitches. Noticed that for music the noise filters in OBS are a bit tight and cut of some of the quieter parts of the music, But since I don’t record music normally that’s just fine.

  • Then I did two recordings of a Podcast. Also 1 minute in the same result. No glitches and a good recording. Noise filters don’t seem to tight, and create a pretty clean audio.

  • Then I thought lets do a recording without the suppression to see if this would trigger the glitches. But no result. Off course a lot more noise in the recording but not the glitches.

  • Then did a recording without any filters and disabled the Noise gate and de Noise suppression. Also in this case a lot more noise. But no weird glitches.

  • All of the previous recordings were recorded with the microphone and receiver quite near to each other. So I did a recording as normal with a bit more distance to each other as well as this might influence the transfer the areal sound signal, since this could be easier disturbed. But no glitches an weird things in the recording.

I was unable to test your theory on the battery and power supply. Our camera is always on power supply because it’s a fixed setup. so the battery pack is dead and can’t record without power supply.

Could it still be advised to do the testing with the SD cart? The use PC has an SSD disk inside to store everything.

Hi Harold 109,

Thanks for the update and the detail on what you were able to test…

Looking at the results, I’m now in two minds as to what your problem might be (assuming you can reproduce the glitches ever again!)

I originally though you have a clock/sync problem, but from your tests and your published results, I’m not totally convinced - it could still be part of the problem.

The other idea is that I would want to investigate your power supply coming into the work and surrounding area. It is possible for a faulty neon/florescent light to indirectly be affecting your mains power and produce ‘spikes’ in the power supply which audio equipment can be susceptible to. Unfortunately it isn’t just lighting that can cause this type of problem. I have in the past encountered fridges, washing machines, tumble dryers and air conditioning units as sources of unwanted pops/spikes/mains hum etc, and none of them where in the same room (or floor in one case) as the recording sessions!

I wouldn’t bother with testing the SD card, that was to rule out any problem with the mixer and OBS, although you might want to consider using the SD as a back-up for your recordings in case anything does go wrong with your mixer/computer/OBS set-up during a session.

Get in touch if you have any further developments - I’m interested to know…



Thanks again for the extensive reply. You are really doing your best to help me out. And I greatly appreciate that. With that being said:

I will keep that in mind. Coming friday I have a new recording session planned. I’m really tense and curious if this issue turns op then. Not only for my self but also for the person I’m recording with.

I understand your point of view and will pay attention to what is turned on at time of recording. Since this is on my work location it’s of course difficult to determine. We do have three bresser Led lights that we use. But the rest of the normal (florescent) lighting is always turned of. But I do must say that quite near the recording studio (5-10m) is an airconditioned server control room. This of course is a “high power” room. I surely hope that this is not causing the issue. Cause moving on of these rooms is not really an option.

I’ll keep you posted through this thread.
Thanks again.


I have some recordings with issues in it.

In the screenshot you can see that I have glitches randomly. Not only random in recording (some not, and some do). But also random in time. I’ve posted an item on this in another channel (Issues with recording studio setup - weird glitches in recordings) where IanT if very helpfull in troubleshooting this issue.

Now I do have at least three recordings with these kind of glitches. I was hoping to repair them and to still be able to use these recordings. But I actually don’t want to spend a ton of hours in doing this all manually. Therefore I’m asking you for help. I’ve searched the youtube channel of Mike to see if there were other alternatives. Firstly I thought of the Paramatric Equaliser. But these glitches seem to have several frequencies and even using 3-4 points in the equalizer doesn’t seem to be able to delete these glitches.

Can someone give me a push in the right direction. I’m not an overly experienced Audition user but I thought I would be able to manage this one.

If this is not repairable then the only thing that is left is trying to record it again.
Thanks in advance for any advice.

Kind regards

1 Like

Great to see some fab tips in this thread. It’s also worth to check the Latency (or I/O Buffer) size in your Audio Hardware settings. Trying to increase this number can sometimes have success with certain audio devices. Failing that do try another audio interface if you can to see if you still get the issue while recording.


I’ll be shure to check whether OBS has such feature as well. I see you used Audition for this screenshot. I’ve done some research in my studio as well and came to the following conclusion:

By using my laptop to record the audio and OBS to record the video i get fine recordings and no glitches, therefore I’m thinking these glitches come either from a faulty HDMI cable which is used to input the signal into the capturecards, the other option is somewhere in OBS or the PC. Where we are already busy updating drivers and flashing the bios. In the taskmanager I can see ethernet activity from OBS that matches the dropout that I have in my audio as well.
I’ll keep this post updated.

KR Harold109