Focusrite 2i2 not showing up in System Preferences

Hi Guys,

I’m having a problem with a new Focusrite 2i2 not showing up in my Sound panel in system preferences. The USB light is on and the channel is receiving input from the mic.
I’m on MAC OS 10.9. I’ve tried a couple of suggestions from different forums but no luck. What’s interesting is that if I have parallels open and plug in the 2i2, Mac OS prompts if to connect the 2i2 to parallels or mac os.

Any suggestions or ideas of what else I can try to solve this?

Hi @jameel_n, the only thing I could find was the troubleshooting guide, Focusrite TSG but maybe you already read that.


Hey Juan, yea I tried that already. I reached out to focusrite tech support and their response was that it may work with mac os 10.9 but it hasn’t been tested. So from the looks of it I may have to update my os. They requested a system report for my system so I’m waiting on a response from them on that.

Problem solved! Updated my os to high sierra and all is well so far.