Echo Settings - ms vs bpm

After studying the live stream “How To Build A Killer DJ Intro” on Monday 26th Sept 2017, I think I might have worked out what was bewildering Mike, and myself with the ms vs beats conversion.

At 35:50 is when he started his ‘new discovery’. :slight_smile:

Please Note: All of what I typed below was making sense of course, but upon watching the stream at that point a few times, Mike did point out the timings were for 120 bpm and not 128 bpm which IS what he set in the preferences. So I’m at a loss as to why it’s doing it. We’ll just stick to that calculator website for now.

Anyway, here’s my study chatter:

The time was calculated as 469 ms on that web page.

So of course you enter that in the ‘ms’ value.

When Mike changed the delay time units to ‘beats’, it changed the beat to 0.94, which I think could be possibly a more precise value.

But then when Mike changed to beats, and set it to 1, then changed the time units to ‘ms’, it changed the ‘ms’ to 500.

So, 469 ms is possibly a true precise value of 0.94 bpm, but it doesn’t explain why swapping it around would give 500 ms for 128…

And that’s when I realised what Mike had said which was it is giving settings for 120 bpm and not 128 bpm.

So it’s got me stumped for now. Maybe my chatter can trigger someone’s thoughts. It’s something I’ve never used before. I’ll do some further digging when I am not falling asleep.

Thanks for reading. Good luck!



Are you referring to today’s live stream (which I haven’t watched yet)?

Today’s date is Tuesday 26th Sept 2017 :slight_smile:

Oops. Thought it was Monday tonight for some reason.

Oh well. Enjoy the stream!


Thanks for posting this up @Mr-Shortcuts. This has really got me stumped too!

I found in the Echo effect inside Adobe Audition you can change the Delay Time Units from ms (milliseconds) to beats (perfect for BPM jingles).

I set the beats to 1 on the left channel and 0.50 on the right channel.

Despite doing this and having the multitrack tempo set to 128 bpm (as you can see in the above screen shot) it appears to default to 120 bpm. When I flip back to ms I get 500 ms on left and 250 ms on right as shown in the screen shot below.

Anyone with an idea on how to get this effect to match the set track bpm as that would be awesome!

1 Like

The plug in is taking the BPM from Preferences under Time Display

Scroll forward to 36:40 in the stream @cyberlarson and see what goes on. Mike does actually set the time to 128 bpm, so I don’t know what Audition thinks it’s doing. It must be getting its time from somewhere else? Perhaps it figures 120 bpm is a ‘common speed’? But I don’t think so. It has to be determined from somewhere.

I missed what he did there. I didn’t know that even went into preferences. Learn something new every day.

That’s exactly what I said to him lol

I submitted a bug report to Adobe regarding this. Let’s see what happens :slight_smile: