Desynchronized audio during recording

Hi there! Together with my friend we’ve encountered a weird issue during our first attempt at recording a podcast. We couldn’t synchronize audio from the microphone (MXL-990) with video from the camera.

After a lot of deductive tests we’ve figured out that our audio interface (Behringer U-Phoria UMC204HD) seems to skip some samples during recording, causing the recorded sounds earlier and earlier than they supposed to. The longer the recording, the larger the discrepancy.

Here’s an example:

The top timeline shows the audio recorded with the Behringer, the bottom one shows audio extracted from the video camera recording at the same time. There was a loud “clap” noise made both at the beginning and around the 10min mark.

At the beginning the claps happen at the same time

:point_up: but after 10 minutes they are already desynchronized.

We’ve tried comparing it with multiple other video cameras, and the result was always the same - the Behringer audio appeared to early.

We’ve tested it using Audacity and Ardour on Linux and using GarageBand and Oceanaudio on Mac. We’ve tried changing sample size and frequency, but nothing helped.

Could it be that our interface is faulty?

Hi kuba-orlik, welcome to the community…
I’m going to assume that you are trying to use two/three digital devices here (camera & audio interface into a computer) and if that is the case I think you will find your problem could be to do with “digital drift”.

This happens if you don’t use some sort of clock generator being sent to the camera and the audio interface simultaneously (genlock springs to mind as older solution to this problem). Each unit is then synchronised with each other correctly and prevents the audio slipping away from the video.

Here’s a link with more information on it which might help you:-

Also maybe try asking @Mike what his set up is for his YouTube appearances… Its going to be more up to date than when I was working on that side of the industry.

IanT.