Audacity Presets - Noise Gate Causing Issues With Running Presets

Problem: Some of our Audacity Preset users get an error message that says: “Noise Gate Script Was Not Recognised” or “Your Noise Gate batch command was not recognised” or “Can’t Find Limiter” etc.

Background Information: Noise Gate was only added natively to Audacity on 15 May 2020 software release which was later withdrawn don’t know why (on their change log) and added back again in v3.0.0 of Audacity. Through further research we now know that some external plugins added to Audacity had issues with that Noise Gate and often resulted in disabling it natively inside Audacity as a result! (Note that our presets are not classed as plugins, they are macros that utilise ONLY native Audacity effects). But if that native effect is disabled - macros will not be able to function properly.

Solution: First of all do make sure that you are on the very latest version of Audacity before anything else. Aside of that the only known solution to this problem is to uninstall Audacity from your computer, delete all files associated with Audacity and then download the latest version of it from official Audacity website here: Two steps here are ESSENTIAL for the fix to work:

  1. The files left by Audacity on your computer have to be removed completely before the new install is done. We have seen instances where that’s not done and results in the the issue not being resolved. Follow this guide on how to do this correctly on Mac and this one on Windows.

  2. New Audacity needs to be downloaded from Audacity official website - this is the only way to ensure you are getting the latest version of Audacity untainted by other plugins etc.

In addition, if you are using external plugins on Audacity - make sure that they don’t disable native functionality and use only current versions of those plugins. This could especially be true for plugins that are designed to reduce noise. Many of the plugins for Audacity that have stopped updates since 2020 would be the core of the issue here.

If you have any further issues - please let us know in the comments below.

UPDATE - 18th May - For International Audacity Users

Some of our international users faced the same issue. It turns out that the language is the issue. Look at the message from Simon from Germany below:

The problem is the language. I am using the German version. The Plugin has been translated. It is not called „limiter“ but „Begrenzer“. But your preset is looking for „Limiter“. I manually changed it to „Begrenzer“ and now it works.


I bought the VO-plugin for the USB mic and get the same error: “Noise Gate Script Was Not Recognised”. I tried reinstalling the software. No luck.
My next step was to look at the macro and I build the NoiseGate rule by hand. I discovered that the name of the NoiseGate has changed:


The new version of Audacity calls it Noise-Gate instead of NoiseGate.

After changing that the plugin works great!
I hope this helps other people with this problem.


1 Like

Thank you for bringing this issue to our attention and for finding the solution on your own. Your efforts in discovering the new name of the NoiseGate and making the necessary changes to get the plugin working is greatly appreciated. I will make sure we update our documentation
and presets accordingly to help others who may encounter this issue in the future.

Thank you again for your help!

1 Like

@Mike Hi Mike, I bought the audacity preset and it seems that I have the same problem as ruben but I tried to do the same and it doesn’t work. Could you help me?

Here is error message that I have:
Capture d’écran, le 2023-02-23 à 12.19.33

Many thanks for your help

Hi Florian, could you please confirm that you have done a completely clean install of Audacity (removing all the files left by previous install, before doing a new one)? This is a must step that clears up all the issues. Cannot be missed :slight_smile: